Jump to content


Photo
- - - - -

Threw a CEL

CEL 2ZZ IACV Idle High

  • Please log in to reply
7 replies to this topic

#1 Cody_2ZZ

Cody_2ZZ

    Senior Member

  • Members
  • 229 posts

Posted 12 October 2012 - 10:06 PM

Hey guys/gals, I threw a CEL yesterday and I'm 90% sure it's the IACV. I've been having some issues with the car idling high recently, and it's been getting progressively worse. It's been annoying starting from a dead stop in first gear and just getting on my nerves in general. Well yesterday the light went off and the idle got even worse. It fluctuates slightly and is almost always high, even when the motor's warm.

Anyone else had this problem?

I bought some electronics cleaner and am going to remove the IACV sometime this weekend and clean it out. Hopefully that should fix it. Unfortunately, I don't have anything to check the CEL code.

Function >>> Form - forever lurking -


Posted Image


#2 danimal86

danimal86

    Junior Member

  • Members
  • 61 posts

Posted 12 October 2012 - 10:13 PM

go to a parts store (autozone/pepboys) and they'll check it for free.

You can get some cheap code reader for around $30
2006 Matrix Xr
Installed: DDM 4500K 55w HID's Morimoto Mini H1 Bi-xenon Projectors (XB-35 Bulbs & Denso Ballasts),(E-Bay) SRI Injen CAI, Pioneer Avh-P3200DVD (With add-on bluetooth & Navi) Avic-X940 Bt, Infinity Components (front) RF Prime 6.5 (rear), DC Header, JL 500/1 and 10w6, TRD Axle Back Exhaust, Camcom, TRD STB, Progress RSB, Scion TC Wheels Stock 16" 5-Spoke, Scanguage II, VLED V3 Triton Brake Lights, VLED: Interior reverse and flashers,

Next: Fx-R 3.0 retrofit LS460 Retrofit, Rear Disc Conversion

#3 FinalGear

FinalGear

    Guru

  • Members
  • 1,786 posts

Posted 12 October 2012 - 10:47 PM

have you clean the MAF sensor
have you replace your PVC

#4 Cody_2ZZ

Cody_2ZZ

    Senior Member

  • Members
  • 229 posts

Posted 12 October 2012 - 11:04 PM

I cleaned my MAF sensor recently and I've never replaced the PCV.

Perhaps I should just clean all three and see what happens. I'm planning on taking the car to the dealership soon for an oil change so maybe they could check out the CEL there.

Function >>> Form - forever lurking -


Posted Image


#5 danimal86

danimal86

    Junior Member

  • Members
  • 61 posts

Posted 13 October 2012 - 02:23 AM

cleaning your MAF will do nothing
2006 Matrix Xr
Installed: DDM 4500K 55w HID's Morimoto Mini H1 Bi-xenon Projectors (XB-35 Bulbs & Denso Ballasts),(E-Bay) SRI Injen CAI, Pioneer Avh-P3200DVD (With add-on bluetooth & Navi) Avic-X940 Bt, Infinity Components (front) RF Prime 6.5 (rear), DC Header, JL 500/1 and 10w6, TRD Axle Back Exhaust, Camcom, TRD STB, Progress RSB, Scion TC Wheels Stock 16" 5-Spoke, Scanguage II, VLED V3 Triton Brake Lights, VLED: Interior reverse and flashers,

Next: Fx-R 3.0 retrofit LS460 Retrofit, Rear Disc Conversion

#6 JBCeliRolla

JBCeliRolla

    El Problematico

  • Moderators
  • 2,150 posts
  • LocationPuerto Rico
  • Vehicle(s):2006 Corolla CE AUTO
    1975 Jeep CJ5

Posted 13 October 2012 - 04:35 AM

verify first the code at AZ...

From Los Tecatos de la Velocidad Crew


Posted Image

Just a lil' boost


#7 Cody_2ZZ

Cody_2ZZ

    Senior Member

  • Members
  • 229 posts

Posted 13 October 2012 - 05:38 PM

cleaning your MAF will do nothing


And why exactly is that?

Function >>> Form - forever lurking -


Posted Image


#8 Cody_2ZZ

Cody_2ZZ

    Senior Member

  • Members
  • 229 posts

Posted 14 October 2012 - 01:43 AM

I checked the CEL today and it was P0505. Strangely, the CEL turn off right before I went to plug in the diagnostics comp. After cleaning the air filter and MAF, the car runs fine again. I'm going to go ahead and clean our the IACV just for good measure and maybe do a fuel injector service.

Function >>> Form - forever lurking -


Posted Image






Also tagged with one or more of these keywords: CEL, 2ZZ, IACV, Idle High

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users